Home > java, Web services > Could not see my WSDL using Apache Axis 2 with Eclipse WTP

Could not see my WSDL using Apache Axis 2 with Eclipse WTP

I have spent some time figuring out why I could not see any WSDL despite everything else seemed to be OK.

After having followed these kind of steps: Creating web services with Eclipse (Bottom up) it appears that I could not see any WSDL.
So I have typed http://localhost:8080/Axis2/axis2-web/index.jsp , then clicked on services and the following screen was displayed:

Axis main screen

Axis main screen

The service  – Converter – seemed to be running ! but when trying to reach the WSDL by clicking on the Converter link I had this:

WSDL page

WSDL page

After some experiments I have found that the WSDL was actually correct (!) . it was just not displayed in Safari. Running the same URL on Firefox confirmed it.

It’s not the first time something is hidden by Safari unfortunately. It seems it waits a really clean html code. It’s still viewable by clicking on view-> view Source but you don’t expect immediately such a thing to happen.

Advertisements
Categories: java, Web services Tags: , , ,
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: